Ascio Phone line down
Incident Report for Ascio
Resolved
We are now able to receive support phone calls as usual.
Thank you for your patience as we worked to resolve this issue.
Posted Feb 13, 2024 - 14:39 UTC
Update
We are continuing to investigate this issue.
Posted Feb 13, 2024 - 13:27 UTC
Investigating
Please be informed that we are experiencing issues with our telephone line at the moment.
Kindly contact us via email or chat for your requests in the meantime.
Posted Feb 13, 2024 - 13:20 UTC
This incident affected: Reseller Support.